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Getting Started 

v  OBO-Edit is the tool we use to edit the ontologies. It can also be used to 
browse the ontologies. 

v  Download the latest release (2.2) of OBO-Edit from: 

•  https://sourceforge.net/projects/geneontology/ 

•  You should download the release specific to your computer (mac/pc/
unix). 

v  Load OBO-Edit by selecting the OBO-Edit icon 



Setting Your ID Range 
v  Choose your individual set of GO ID’s by editing and committing the numbers file in the 

go directory (see CVS tutorial: you will need a cvs account for this step) 
•  go/numbers/go_numbers 

v  You then need to set this range in OBO-Edit.  
•  Metadata -> ID Manager 

•  Click the cog icon, and edit the ‘Default rule’ line to be:  
•  GO:$sequence(7,00XXXXX,00XXXXX)$. 
NB: use your set of assigned numbers instead of XXXXX. E.g. for ID range GO:
0098001 -  GO:0098500, paste: 
 GO:$sequence(7,0098001,0098500)$.  
 

•  Close the ID manager. 
•  This will generate IDs with the prefix GO, that are 7 digits long, beginning with 

00XXXXX. (E.g. GO:0098001) 
 



Choosing a Layout 
v  You can configure your OBO-Edit layout how you like.  

v  There are two main types of panels you can have in OE: 
•  Viewer: Allows you to see the parentage/graph layout etc of a term WITHOUT being able to make 

changes 
•  Editior: Allows you to make changes to your term or its relationships 

v  I would recommend the following layout (see next slide for diagram): 
•  2 x Ontology Tree Editor (Use to create new terms, move terms, delete terms) 
•  1 x Tree Viewer (Can be useful to view the ancestors of your terms) 
•  1 x Parent Editor (Useful to view and edit the immediate parents of a term) 
•  1 x Search Panel 
•  1 x Text Editor (Use to edit the definition/synonyms/Xref for a term) 
•  1 x Verification Manager (Use to check there’s no errors in your edits) 
•  1 x Graph Viewer (Useful to view a snapshot of the ontology, up to the root) 



A Suggested OBO-Edit Layout 



Rearranging Your OBO-Edit Set-Up 
v  Use the top menu to add a new Viewer or Editor panel to your layout.  

•  Just click on the panel type you’d like to add, and OE will add it in. 
 
v  Your panels can be arranged as tabs, or as separate windows in OE. They can 

be expanded or shrunk as required. 

v  To move a panel, click on the top bar and drag your panel until the black 
outline is where you want it. 

v  To remove a panel, just click on the ‘X’ in the top right corner. 

v  To maximize a panel, just click on the ☐ icon in the top right corner. 
•  You can minimize or restore to undo. 

v  OE can be a bit click-happy when you’re rearranging your panels. If it all goes 
awry, I’d suggest removing the offending panel and adding it back in afresh. 



Loading an Ontology 

v  You can load an ontology by: 
•  1. Loading a flat-file 
•  2. Loading from a URL 

v  If you are committing your changes back to the go-trunk 
directory, you will need to load a svn-updated flat-file 
from go-trunk/ontology/editors/
gene_ontology_write.obo 

v  Loading from a url is a quick way of viewing GO without 
having to download the very recent copy of the GO file. 



Loading an Ontology: Flat File 
v  File -> Load Ontologies 
v  Replace <create new profile> with an identifiable name (E.g. GO), and Click ‘Add’ to add in a new 

profile. 
v  Browse to find the link to gene_ontology_write.obo in the go-trunk directory: 
v  Click Ok 

 
You can store as many profiles as you like in the settings so you can quickly load other ontologies such as cell ontology, 
GOCHE, anatomy ontologies etc. 



Loading an Ontology: URL 

v  File -> Load Ontologies 

v  Replace <create new profile> with an identifiable name (E.g. 
GO_URL), and Click ‘Add’ to add in a new profile. 

v  In the ‘Path or URL’ box, type: 
•  http://www.geneontology.org/ontology/gene_ontology.obo 

v  Click ‘Ok’ 



Editing An Ontology 



Creating a Term (in an existing ontology) 

v  In an Ontology Tree Editor, click on the term that will be a parent for your new term. 
v  Hold down the ‘Cmd’ key, and left-click on the mouse to bring up a menu (on a mac) 

v  Scroll down to ‘Create new child’ option 

•  OBO-Edit will create a new term using the next free ID in your range 

•  The child term will automatically have an is_a relationship to its parent: this can be changed 
later 

•  All information about an OBO term is displayed and edited in the OBO-Edit Text Editor 
panel 

 



Naming and Defining a Term 
v  In the Text Editor box, fill in the term name and term text definition. See the GO documentation about 

naming and defining terms. 

v  Each definition needs at least one reference (Dbxref) so we can go back to the source, if needed. To add a 
Dbxref, click on the ‘+’ in the Text Editor panel. 
•   In the Database box, fill in a prefix: 

•  GOC (used for curator initials) 
•  PMID 
•  ISBN 
•  http 
•  CHEBI 
•  VZ 
•  PR 
•  [other anatomy abbreviation] 

•  In the ID box, fill in the curator initial (e.g. bm), PubMed ID, ISBN ID, web address, or other ontology 
ID. 

•  Click on ‘+’ to add in another Dbxref. There is no limit on how many definition references a term may 
have. For most terms, it’s good practice to have at least a PMID and curator initials (e.g. GOC:bm). 

 

NB: For curator initials, check: go/doc/go.curator_dbxrefs 



Dbxref library (optional) 

If you’re going to use a DBXref often, you can store commonly used Dbxrefs in a Dbxref 
library: 

v  Metadata -> Dbxref Library 
v  Click on ‘Configure dbxref’ 

v  Click on ‘Add’ 

v  Fill in the Database name and ID tabs 

v  Save configuration, and your Dbxref will appear in the Dbxref Library 

v  To add the Dbxref to a term, click on a term in the Ontology Tree Editor, 
and in the Dbxref panel, click on ‘Add as def dbxref’. Check in the Text 
Editor that the definition Dbxref has appeared. 



Adding a synonym to a term 

v  In the Text Editor panel, select the Synonyms tab, and click the ‘+’ icon. 

v  Add in an Xref for the synonym (as for the definition Xref). 

The scope indicates how a synonym is related to the preferred tern name. An exact synonym 
means that the synonym string can be used interchangeable with the preferred name in all 
circumstances. The default scope is ‘Related’. Other options are ‘Narrow’ and ‘Broad’. 



Saving your text changes 

v  To save any changes made in the Text Editor panel, click on ‘Commit’. 
•  If you click on another term without saving, OE will bring up a warning. 



Adding New Relationships 

v  To add a new parent to a term, select the child term in one Ontology Tree Editor 
panel. 

v  Drag the term onto its new parent (either in the same Ontology Tree Editor, or a 
second Ontology Tree Editor if the parents are far apart in the ontology). 

v  Add child term (copy) -> [choose the new relationship type from the drop-down 
menu]. 



Changing Relationships 

v  Cmd-click on the child term, and bring up the menu 
v  Change relationship type -> [select one of the options] 

	
  

Remember that all terms 
must have at least one 
is_a parent. 
	
  



Removing Relationships 

v  In the Ontology Editors panel, you can delete a relationship 
by Cmd left-mouse-click on the child tem to open the menu, 
and selecte ‘Delete relationship’. 

 
v  Alternatively, parents can be removed in the ‘Parent 

Editor’ by clicking on the ‘waste basket’ next to the Parent 
Term. 



HAS_PART 

v  Remember that HAS_PART relationships are displayed the opposite way to is_a, 
part_of and regulates relationships: 

v  An epidermal growth factor-activated receptor will ALWAYS bind to EGF:	
  

	
  
. 



HAS_PART 

v  One of the easiest ways to view HAS_PART relationships in OBO-Edit is using the 
Graph Viewer or the Parent Editor 

	
  
. 



Ontology Tree Editors 
v  The Ontology Tree Editors can be in two modes: Home or Global. 

v  In home mode (house icon), the term chosen in the editor panel will NOT appear in 
other Editor/Viewer panels. 

v  In global mode (world icon), the term chosen in the editor panel WILL appear in other 
Editor/Viewer panels. 

v  If you have more than one Ontology Tree Editor in your OBO-Edit layout, the default 
setting is that only one Editor can be on Global mode at once. 

v  These modes are useful if you are dragging a term between two editing windows: it is 
useful for the Editor containing the parent to be on Home mode. 



Destroying a Term 

v  Destroying a term is NOT the same as obsoleting a term. A term should ONLY be 
destroyed if it has not yet been committed to the live ontology: E.g. if it has been 
added in OBO-Edit by mistake or as part of your local edits. 

v  Destroying a term removes it from the ontology forever and allows the ID to be 
reused. 



Obsoleting Terms 
v  Obsoleting moves a term to the ‘Obsolete’ parent. These terms are still displayed in red at the 

bottom of OBO-Edit, and the ID can NOT be reused. 



Obsoleting Terms 

BEFORE obsoleting a term, go to the Text Editor: 
 

v  In the ‘Comment’ tab, describe the reason for obsoletion. E.g. 
•  This term was made obsolete because its definition was inaccurate. 

•  This term was made obsolete because 4-nitrotoluene is not synthesized by living organisms, and GO 
does not cover non-biological processes. 

•  This term was made obsolete because it represents a gene product. 

v  In the ‘Definition’ tab, type ‘OBSOLETE’ at the start of the term definition. 



Obsoleting Terms 

v  A term can only be obsoleted if it has no children and only one parent. Therefore, in 
the Ontology Tree Editor or Parent Editor, you need to delete other relationships in 
the ontology. Once only one parent-child relationship remains for the target term, a 
‘Delete term (make obsolete) option will appear in the drop-down menu. Click on 
this. 



Replacements/Suggestions for 
Obsoleted Terms 

v  To point to a replacement term for an obsoleted term, select and drag the 
replacement term onto the obsoleted term, in an Ontology Editor Panel. 

v  Choose the ‘Add replacement term’ 

 

v  For alternative terms that could be considered, choose the ‘Add consider term’. 

These are displayed in OBO-Edit and in some web browsers so annotators can reassign annotations. 



Making terms disjoint 
v  Having added terms to the ontology, we may wish to exert some restrictions on how these classes 

can be used. 

•  For example, the ‘biological process’, ‘molecular function’ and ‘cellular component’ top 
level terms are disjoint: this means that an instance can belong to one or the other but not 
to both.  

To assert that classes are disjoint: 

v  Select the term, and drag it over the term it should be disjoint to 

v  Choose Add child term (copy) -> disjoint_from: 



Undo 

v  Don’t worry if you make a mistake. Just: 

•  Edit -> Undo 

 



Help 

v  A Help manual is built into OBO-Edit. 

v  Help -> User Guide 

 



Verification Plugin:  
Checking for typos, dodgy parentage, terms of the same name etc  

OBO-Edit has a comprehensive set of verification checks to help maintain consistency in 
the ontology. These checks include a dictionary for definitions, synonyms and term 
names, a check for disjoint violations, for cycles in the ontology, and a check for name 
redundancy. The verification tool is also configurable so you can specify your own checks, 
and specify when and how the checks are run. 
 
v  Tools -> Verification Manager 
v  Ensure the tab Configuration is checked, and check all the boxes in the ‘On Manual’ 

column. Hit ‘Run manual check now. 
v  Results will appear in the ‘Verification Results’ Tab. 
v  To test, try adding a spelling error and re-running the manual check. 

Jenkins also runs a more extensive Verification Manager after each svn-commit to check for errors. 
Any errors that cause the build to fail are automatically mailed to the ontology editors mailing list. 



v  This is an example of how to set up your Verification manager. The next few slides 
are additional checks that can be added in. 

 



Empty DBXref check 

…	
  useful	
  to	
  double-­‐check	
  you	
  haven’t	
  filled	
  in	
  any	
  defini7on	
  DBXrefs	
  without	
  
a	
  prefix	
  or	
  a	
  curator’s	
  ini7als,	
  for	
  example.	
  



Is_a complete check: checks every term has an is_a parent 

NB:	
  the	
  check	
  is	
  set	
  up	
  this	
  
way,	
  because	
  if	
  you	
  set	
  it	
  
up	
  to	
  look	
  for	
  missing	
  is_a	
  
links	
  directly,	
  OBO-­‐Edit	
  
doesn’t	
  recognise	
  the	
  
disjoint	
  rela7onships	
  
between	
  the	
  top	
  terms,	
  so	
  
produces	
  a	
  lot	
  of	
  errors.	
  
This	
  is	
  a	
  way	
  to	
  get	
  round	
  
that.	
  
	
  
hJps://sourceforge.net/
tracker/?
func=detail&aid=3024334&grou
p_id=36855&a7d=418257	
  



Namespace 

Checks	
  that	
  you	
  haven’t	
  made	
  a	
  biological_process	
  term	
  as	
  a	
  child	
  of	
  a	
  
cellular_component	
  term,	
  for	
  example.	
  



Saving Files in OBO-Edit 

v  File -> Save As. A Write Ontology dialog will appear 
v  Click the Advanced button to view the advanced save interface. 

v  Ensure the output type is set to OBO_1.2, and click Add to create a new save profile. 

v  Set the path and filename to save to 

v  Finally, at the top where it says <create new profile>, give a name to your profile. 
Once you have saved once,  OBO-Edit will remember this profile for future sessions. 
Hit ok. 

The ontology is 
now saved on 
YOUR machine, 
and can now be 
committed to the 
go directory using 
svn (if you have an 
account). 



Reasoning 

Reasoners can be used for to check consistency and automatically classify ontologies.  

v  Reasoner -> Reasoner manager 

v  Toggle to ‘RuleBasedReasoner’ 

 

The Reasoner will run and flag up any unnecessary relationships or inconsistencies 

 

The Reasoner takes a lot of memory to run, so it’s recommended to have the Reasoner switched 
OFF when doing daily edits in OBO-Edit. 
 

You can run the Reasoner as an additional check (once a month). It’s also run by ontology 
managers to flag up any problems. 

 

Other Reasoners are available that can automatically place terms in the hierarchy. 



Some Handy Extras 



Using Graphviz 
Graphviz is an external application. To use Graphviz in OBO-Edit, you need to do a short set-up: 

 

v  To open a Graphviz panel: Viewers -> Graphviz 

v  In a web browser, download Graphviz from: http://www.pixelglow.com/graphviz/.  (this is a 
mac-specific version) 

v  You need the ‘dot’ file: this is the program OBO-Edit uses to create Graphviz displays. 

v  To set the path, click the spanner icon on the Graphviz Viewer. 



Graphviz 
v  When correctly configured, Graphviz should look like below. Colours, shapes etc. can all 

be configured using the Graphviz configuration manager (click on the Graphviz spanner). 



Rendering and Filtering 

v  It can be useful to have different terms showing up in different fonts or colors. 
v  In the Ontology Tree Editor, click the spanner icon. 

v  Scroll to ‘Term renderers’ 

v  To add a new render, click on the + button. 

v  Fill in the fields, and choose the Foreground/font face changes. 

v  Check that the changes appear in the Ontology Tree Editor. 

For example, if you are working on a particular field, you can set it so that all terms containing 
‘neuron’ in a name or synonym show up as red.  


