OEWG 20111207

From GO Wiki
Jump to: navigation, search

OBO-Edit Working Group Meeting: Tuesday, December 6, 2011, 8:30am PST

Conference call numbers:
US: 1 866 953 9688
UK: 0808 238 6001
PIN: 801561

Agenda/Chair: Nomi Harris
Minutes: Nomi
Attendees: Nomi, Heiko, Midori, Ramona, Chris, Becky

Bug and Feature Trackers

Discussion

  • Mike Cherry tested 2.1-rc3 in the GO pipeline and said it all looked fine except the obo 1.0 format output was slightly different. Chris M said that didn't matter; no one uses obo 1.0 anymore anyway.
  • Can't save cross products (in OE1 or OE2)
    • Some users said that when they created cross products, in OE, they weren't getting saved properly. Alex wrote, "I also made a few cross products today -- or one the wrong genus term got saved, for another no genus term got saved." However, he could not find a repeatable example of this problem.
    • I tested cross-product creation and at first it seemed to me that there was a bug--the genus you saved would sometimes convert to a different one. But it turned out that what was happening was that the autocomplete dropdown for the genus field offers you synonyms as well as term names, but if you choose one that happens to be a synonym, the cross product editor silently converts that to the primary term name, since there isn't a term with the name you selected. That may not be desirable behavior, but it's not actually a bug--the changed genus is not just random.
    • I was unable to find any other examples where the cross-product editor lost or messed up the genus name. If there are other cases where it misbehaves, I need examples.
    • I have made the behavior easier to understand by implementing a requested feature: Show IDs as well as term name/synonym in the Genus box
      • This was a very localized change (only affects the Cross Product Editor) and should not affect any other OE behavior.
    • While testing this, I noticed that the autocomplete list in the Cross Product Editor includes some "java.lang.Objects", like the Search autocomplete list used to. Unfortunately, I can't fix this the same way, but I'm looking into it and should be able to fix it.
  • Alex reported several other bugs he had noticed. All are pre-existing (already reported) and/or sporadic and not repeatable. I don't think any of them are new bugs.
  • Serial read/write are broken (have been for a long time). I tried to fix them, but they are hard to fix. We concluded that the serial adapter is not important, and we can just get rid of it now. (It's not used for anything---autosave uses obo format.)
  • A user was doing a filtered save and ending up with a dangling reference. This was not an OE bug; it was fixable with a set of filters, which Midori helpfully explained. (Midori, should we add that explanation to the user guide, or is it not a situation that comes up much?)

Fixed since last meeting

Currently working on

Next bugs to work on

Demo - filtered save

If there is interest, Ramona will lead a demo/discussion on how to do filtered saves (i.e., how to create slims).

Everyone is welcome to chip in with tips and suggestions.

(The user who had asked the question about filtered saves didn't call in, so we didn't do the demo.)

Links

Back to OEWG meeting agenda and minutes list